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Licenses and Trademarks 
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All other product names mentioned in this manual may be trademarks, and if so, are trademarks or registered trademarks of their 
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Disclaimer 

NIMBLEGEN SYSTEMS, INC. MAKES NO WARRANTIES, EITHER EXPRESS OR IMPLIED, REGARDING THE SIGNALMAP 
COMPUTER SOFTWARE PACKAGE, ITS MERCHANTABILITY OR ITS FITNESS FOR ANY PARTICULAR PURPOSE. THE 
EXCLUSION OF IMPLIED WARRANTIES IS NOT PERMITTED BY SOME STATES. THE ABOVE EXCLUSION MAY NOT APPLY TO 
YOU. THIS WARRANTY PROVIDES YOU WITH SPECIFIC LEGAL RIGHTS. 
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Preface 

What is SignalMap? 
SignalMap™ enables you to visualize NimbleGen array data. It provides the 
ability to: 

♦ Import one or more GFF (General Feature Format) files. 

♦ Visualize tracks of data organized into panes and tracks. 

♦ See peak correlations between your data and annotation tracks. 

♦ Link to a web site with detailed information for a selected gene. 

♦

♦ Print and export screen captures. 

NimbleGen 
representative for more information or to extend your license. 

 Export a subset of your data. 

Licensing 
You can use SignalMap to visualize NimbleGen array data. Usage of this 
program or its components for other commercial/non-commercial entities 
purposes is strictly prohibited. Read license.txt on the SignalMap software 
CD for details on your current licensing agreement. Contact a 
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Requirements 
SignalMap runs on computers with the Microsoft® Windows® operating 
system. Following are the system recommendations and requirements: 

♦ Pentium III 600 MHz (Pentium II 450 MHz minimum) or equivalent 

♦ 384 MB (256 MB minimum) RAM 

♦ 384 MB (256 MB minimum) Virtual RAM 

♦ 10 MB free space on your hard drive 

♦

minimum) 

 Microsoft Windows 98/ME/2000 XP  (Windows 98 minimum) ® ®

♦ SXGA 1280x1024 with 16-bit colors (SVGA 800x600 

♦ Hardware graphics drivers recommended 

♦ Standard keyboard and 2-button mouse 

Note:  To increase  SignalMap performs best with large amounts of memory.
efficiency, close other programs while using SignalMap. 

Installing SignalM
ap from the CD or from files downloaded from 

 the installation program. Follow the on-screen 
installation instructions. 

ap 
You must install SignalM
NimbleGen’s web site. 

Click Install.bat to launch
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For detailed installation instructions, see ReadMe.txt on the CD or 
bleGen’s web site. Nim

! CAUTION:  Although NimbleGen has performed every effort towards  
providing a stable product, the Company is not responsible for system 
errors or data corruption from using this software. 

Technical Suppo
technical-services@NimbleGen.com. 

To report SignalMap software errors, see Appendix B, Reporting Bugs. 

rt 
If you have trouble working with SignalMap, email your questions to 
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Chapter 1. Basic Concepts 

To use SignalMap effectively and efficiently, you need to understand the 
basic concepts underlying this software. In this chapter, you learn about: 

♦ A typical session for using the software 

♦ The elements in the SignalMap interface 

♦ GFF (General Feature Format) files 

♦ Printing your data 

Using SignalMap: A Typical Session 
The following is a broad overview of a typical session using SignalMap. 

To use SignalMap: 

1. 

2. Choose File -> New to create a new document window. 

Start the SignalMap software. The SignalMap program window appears. 

3. Import your data files. For more information, see “Importing Data” in 
Chapter 2, Importing Your Data. 

4. Browse your data. For more information, see “Viewing Panes and 
Tracks” in Chapter 3, Browsing Your Data. 

5. Export your data or screen capture. For more information, see “Exporting 
Your Data” in Chapter 4, Exporting Your Data. 

6. Print a screen. For more information, see “Printing Your Data” in this 
chapter. 
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The SignalMap Interface 
When you import files into SignalMap, a window similar to the following 
appears: 

 

Toolbar 
Use the buttons on the toolbar to quickly access SignalMap features. 

Tip: You can display or hide the toolbar by choosing View -> Toolbar. 

Tip:  You can move the pane selector by dragging it with the mouse. 

Create a new document 
Creates a new document (or window) in which to import data. The first new 
document window is called GFF1. Subsequent windows opened in the same 
session are named sequentially, GFF2, GFF3, and so on. 

Import Files 
Imports existing GFF files, saved with either a GFF or TXT filename 
extension. You can import several GFF files at a time. 

Print Preview 
Displays a preview of the current display before you print. 
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Print 
Prints the current display to the selected printer. 

Pointer 
Click to select data or genes. 

For locations on the gene track annotated with web addresses, double-click 
to activate the hyperlink. 

Magnifier 
 Use to zoom in or out of the display in the selected pane. Be aware your 

magnification selections will not affect other panes. 

♦ Click in the display to double the magnification around the center of the 
click. 

♦ Press the Ctrl key then click to halve the magnification. 

♦ Click and drag to magnify an area. 

Auto Scale 
Enables the automatic scaling of the y axis for the selected tracks. 

Manual Scale 
Displays the Manual Scale dialog box, from which you can change the 
minimum and maximum y-axis scale for the selected tracks. 

Increase Point Size 
Increases the height of the data to make it more visible. 

Decrease Point Size 
Decreases the height of the data. 

Panes and Pane Selector 
SignalMap displays the data from a GFF file in panes. Each pane contains 
information corresponding to one seqname defined in the GFF file. Typically, 
a seqname will be the chromosome or region name for NimbleGen-supplied 
data. 

You can select individual panes from the selection box in the pane selector. 
Choosing the All Tracks button displays all tracks. 

! CAUTION: SignalMap replaces an empty seqname with a space. 

Back (Pane History) 
Displays the previous pane in your browsing history. 

Forward (Pane History) 
Displays the next pane in your browsing history. 
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Information and Attributes 
Displays information about the dataset and attributes for the specific data 
point under the pointer. Each line is optional: 

♦ Displays the names of imported GFF files and the time taken to import 
the data. 

♦ Displays the number of loaded rows, positions displayed, and total 
positions. 

♦ Displays the information that corresponds to the data under the pointer. 

Score: The score for the data point. 

Start and End Position: The first and last position for the data point. 

Attribute information: The contents of an optional column in the GFF file. 
Attribute information could include web site links and annotation. 

♦ Displays the information that corresponds to the gray cursor selection. 

Position Scale 
Displays the x-axis scale for all tracks in the pane. This scale corresponds to 
the start and end column in the GFF file. 

Tracks 

 
Each track displays data for different types of features in the GFF file. 

♦ Y-Axis Scale: Displays the y-axis scale information. 

Track Information: Displays t♦ he feature, number of rows, and other 

♦ ray bar is displayed over the track at 
the location of the selected gene. 

information about the track. 

Highlighted Gene: A transparent g
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Status Bar 

Caps Lock 
Displays CAPS when the Caps Lock key is set on your keyboard. 

Num Lock 
Displays NUM when the Num Lock key is set on your keyboard. 

Scroll Lock 
Displays SCRL when the Scroll Lock key is set on your keyboard. 

GFF Files 
SignalMap can import and export GFF files with either GFF or TXT filename 
extensions. For more information about GFF files, see 
www.sanger.ac.uk/Software/formats/GFF/GFF_Spec.shtml or see 
“Understanding GFF File Format” in Appendix A, GFF Files. 

Importing Your Data 
To import data into a new SignalMap document, choose File -> New or click 
the New button on the toolbar. The Import GFF Files dialog box automatically 
appears. Use this dialog box to open the GFF file(s) to load. You can also 
import GFF files by dragging and dropping them into an existing document. 

For more information, see “Importing Data” in Chapter 2, Importing Your 
Data. 

Printing Your Data 
SignalMap prints your data based on the magnification of the display. That is, 
the Print command prints exactly what you see on your screen. Therefore, 
zoom in to the region before using the Print command. (See “Magnifying 
Regions of Data” in Chapter 3 for details.) Data always print to a single page. 

Note: Before you print your data, check your print settings. You may need to 
change the print orientation from portrait to landscape. 

To view or change your print settings: 

1. Choose File -> Print Setup.  
The Print Setup dialog box appears. 

2. Select your printer and print properties.  
For example, you may want to change the Orientation from Portrait to 
Landscape. 

3. Click OK to print.  
Your data prints onto one page. 
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To preview your data before you print: 

1. Choose File -> Print Preview or click the Print Preview button on the 
toolbar. 
A preview of what will print displays in the window, as shown in the 
following image. 

  

2. Click Print… at the top of the preview window to print the data. 

To print your data as shown on the screen: 

1. Choose File -> Print or click the Print button on the toolbar.  
The Print dialog box appears. 

2. Select your printing preferences. 

3. Click OK.  
Your data prints onto one page. 
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Chapter 2. Importing Your Data 

SignalMap can quickly import large GFF (General Feature Format) files, 
importing more than one million rows of data in less than 40 seconds with a 
Pentium IV computer. 

SignalMap performs best when other memory-intensive software, such as 
graphics software, are not running simultaneously. Close any Windows 
software you do not need before importing your data files. 

! CAUTION: Although SignalMap easily imports very large files, it requires 
significant amounts of memory to do so. NimbleGen recommends you 
close other memory-intensive software, such as graphics programs, 
when working with SignalMap to avoid losing information should those 
programs stop responding. If SignalMap stops responding, report the 
problem to NimbleGen as described in “Appendix B. Reporting Bugs.” 

SignalMap organizes GFF data is by seqname, one per pane, then by 
feature, one per track, and then by position. 

In this chapter, you learn to: 

♦ Import data 

♦ Import annotation 

♦ Include hyperlinks 

Importing Data 
You can import any GFF file with a GFF or TXT filename extension into 
SignalMap. 

To import data: 

1. Choose between the following: 

♦ e -> Import or 

♦ cument, choose File -> New or click the 
New button on the toolbar. 

ent window opens, and the Import GFF Files dialog box 
appears. 

 To import data into your current document, choose Fil
click the Import GFF Files button on the toolbar. 

To import data into a new do

A new docum

Tip: Drag and drop GFF files into the current document to import them. 
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2. Select the GFF
select multiple files. 

 files to import. Hold down the Ctrl key while clicking to 

3. 

ing image, provides status 
information that shows the progress of the import. In this example, 
SignalMap has loaded 31% of the third file, representing 46% progress 

Click Open. 
SignalMap imports the files into the document. 

The Import Files window, shown in the follow

towards the time required to import all files. 

 

The following image shows an example of data-only GFF files. 

 

 
reen color. However, data 

tracks frequently are named according to sample ratios (e.g. 
AcK9H3/Total1) or other naming schemes preferred by the researcher 
and will thus display with various colors. 

You will notice some data tracks are displayed in a green color, while 
other data tracks are shown in other colors. 

When data tracks contain the word “data” in the feature field of the GFF
file, SignalMap displays the track with a g
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Annotation 
SignalMap imports annotation (any feature other than data) in the same way 
as any other GFF file. 

Note: To display the track with the colors designated below, the GFF file 
must specify the name of the track in the feature field. If it does not, 
SignalMap displays the track in a different standard color. 

When possible, SignalMap displays certain tracks with specific colors to 
enable you to more easily identify them in the pane. The following image 
provides a typical example. 
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Track color assignments for annotation: 

♦ gene: This track contains information about the start and end of genes. 
You can click a gene to highlight all data in the same position as that 
gene. If web hyperlinks were specified in the GFF file, you can double-
click their location on the gene track to open your computer’s default web 
browser and access the specified web site. Usually displays with a blue 
color. 

♦ exon: This track contains exon data. Usually displays with a brown color. 

♦ CDS: This track contains CDS data. Usually displays with a turquoise 
color. 

♦ start_codon: This track contains the start codon position. Usually 
displays with a red color. 

Hyperlinks 
SignalMap treats any http hyperlink in the GFF file’s attribute field as a 
hyperlink. URLs can also be specified using the GFF3 tag format 
url=someurl. You can separate multiple items in the attribute field with a 
semicolon (;). 

Placing the pointer over a data point containing a hyperlink allows you to 
view the web address. Double-clicking data with a hyperlink opens your 
computer’s default web browser and accesses the specified web site. 

A common use for hyperlinks is to link to web site information about specific 
genes. This would be accomplished by adding URL links in the attribute 
fields for gene feature records. The following lines provide acceptable 
hyperlinks. 

Chr1 NGS track1 20 30 30.0 . . chr info; http://www.nimblegen.com 
Chr1 NGS track1 30 40 40.0 . . url='http://www.nimblegen.com' 
ChrX NGS track1 10 15 20.0 . . http://www.gene.gov/N_001412 
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Chapter 3. Browsing Your Data 

SignalMap allows you to quickly browse your GFF (General Feature Format) 
data. In this chapter, you learn to: 

♦ View panes and tracks 

♦ Reorganize tracks 

♦ Detect peaks 

♦ Search data 

♦

le 

a 

Viewing Panes a

a 

ome or region per pane. The 
 

 or annotation feature. 

When a new GFF file is imported, the first pane is selected by default. 

 Magnify regions of data 

♦ Change the track height 

♦ Change the y-axis scale 

♦ Change the track sty

♦ Change the color 

♦ Highlight track dat

♦ Use hyperlinks 

nd Tracks 
SignalMap organizes GFF data into panes and tracks. Each SignalMap 
document can contain up to 32,768 panes. 

Each pane can contain an unlimited number of tracks. A pane contains dat
tracks corresponding to one seqname. NimbleGen-supplied GFF data will 
usually be organized to display one chromos
name of the pane (seqname) appears above the first track shown, as marked
on the image shown on the following page. 

Typically, each individual track contains only one data
The feature name and other details are printed below the graphical 
representation of the data on the track. 
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To view tracks on a particular pane: 

1. Use the pane selector to select to a pane of interest or browse through 
panes using the history buttons and the up/down buttons. 
SignalMap displays the data tracks for the selected pane (seqname), as 
shown in the following image. 

 

To view all tracks: 

1. Select All Tracks (the top selection in the pane selector drop-down list). 
All tracks appear in the pane, as shown in the following image. 
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The tracks for each seqname appear with alternating color backgrounds 
(white and lime green) to separate the seqname data visually. 

2. Use the window’s vertical scroll bar keys to scroll to the tracks to view in 
this pane. 

To go to a specific location: 

1. Choose View -> Go to Position or press Ctrl + G.  
The Go to Position dialog box appears, as shown below: 

 

2. Select the pane and position and click OK. 
SignalMap displays the pane and positions selected. 
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Reorganizing Panes 
SignalMap sorts newly imported panes in the order that they were in the file. 
You can change the sort preference in the Pane menu. You can also delete 
panes you do not want. 

To reorder panes: 

1. Choose Pane -> Sort. 

2. Choose from the following options. 

♦ Unsorted: Panes are displayed in the order they were loaded. 

♦ Alphanumeric: Panes are sorted alphabetically (case-insensitive). If 
the pane starts with “chr”, the pane is sorted numerically using the 
number following “chr”. 

To delete panes: 

1. Select the pane to delete. 

2. Choose Pane -> Delete.  
SignalMap deletes the pane. 

 

Reorganizing Tracks 
SignalMap sorts newly imported tracks in alphabetic order. You can select 
and move tracks up or down to suit your needs. You can also delete tracks 
you do not want. 

To select tracks: 

1. Using the Pointer tool, select tracks by clicking to the left of the y-axis 
scale of the track. Hold down the Ctrl key and click to select multiple 
tracks. 
The tracks are selected and a blue bar appears over the y-axis scale. 

Note: You can select all tracks by choosing Track -> Select All or pressing 
Ctrl + Alt + A. 

To move tracks: 

1. Select the tracks to move. 

2. Click one of the selected tracks and move them to a new location in the 
pane. 
The selected tracks are moved to the designated location. 
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To 

1. 

2. 

♦ Right-click one of the selected tracks and choose delete. 

♦ Choose Track -> Delete. 

Detecting Peaks 
t your 

data use one of the following procedures to detect peaks. 

Win d Detection 

with a score of the 

ys 

You have the nge the following parameters. 

th of the window in base pairs. 

 

track to create a smooth data 
2 to 

2. ve of the smoothed data. The 

4. 

delete tracks: 

Select the tracks to delete. 

Choose between the following: 

SignalMap deletes the selected tracks. 

SignalMap can detect peaks in your data and display the location of these 
peaks in a separate track. You can then use the peak track to highligh

. SignalMap can 

dowed Threshol

1. Looks for at least 4 data points within a window that are above a 
threshold value. 

2. Groups these points and adds them to the peak track 
maximum value. 

bove the threshold as peaks but displa3. Tags isolated data points a
them in a gray color. 

 option to cha

♦ Peak Window Size: This is the wid

♦ Peak Threshold: This can be specified as a percentage of the maximum
data or as a score. 

Second Derivative Peak Detection 

Averages the data over the range of 1. the 
set. The negative values are discarded. In addition, an optional log
linear conversion is applied to detect peaks in log2 data. 

Calculates the negative 2nd derivati
negative values are discarded. 

3. Multiplies the smooth data and the 2nd derivative data. 

Detects peaks from this data by searching for all points above a 
percentage of the maximum data. 
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You have the option to change the following parameters: 

Peak Window Size:♦ width of your peaks in base pairs. 
 width and for the derivative kernel width. 

♦ smoothing position. 
Smaller values will detect more peaks but will take longer to process. 

♦ maximum value that should be 

1. 

2. d choose Find Peaks, or choose 

3. 

eters 

 The approximate 
This is used for the smoothing

Smooth Step: The number of bases between each 

Peak Threshold: The percentage of the 
called as a peak. 

To detect peaks: 

Select the tracks in which to detect peaks. 

Right-click one of the selected tracks an
Track -> Find Peaks. 

Select the detection method. 

Windowed Threshold Peak Detection Param
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Second Derivative Peak Detection Parameters 

 

4. Adjust the parameters and click OK.  
A new track displays under each selected track. 

 

5. To highlight the peaks in the track, select the new peak track, and then 
right-click and choose Attach Cursor. 
SignalMap highlights the detected peaks. You can now select peaks with 
the mouse or by using the arrow keys. 
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Searching 
SignalMap can search for keywords or do regular expression searche
attribute column of your data. 

To search your data: 

1. Choose Edit -> Search or p

s in the 

ress Ctrl + F. 
g box. SignalMap displays the Search dialo

 

2. Select the Regular Expression check box if appropriate. 

3. Type the search keyword or regular expression and click Find. 
SignalMap searches for your keyword or regular expression in the 
attribute column of your data. The results are displayed in the dialog box. 

4. Double-click the item you are interested in. 
SignalMap displays the item and highlights it with a selection bar. 

gions of Data Magnifying Re
Sign
inde
inte r example, you may want to 
magnify areas where spikes in your experiment data track correspond to 
gene and/or exon annotation. 

To zoom in (increase magnification): 

1. Choose View -> Zoom In or click the Zoom button on the toolbar. 
The cursor becomes a magnifying glass. 

alMap maintains magnification and scroll position for each pane 
pendently. Use the Zoom tools described below to magnify areas of 

rest in your data and annotation tracks. Fo
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2. Choose between the following: 

♦ Click the track in the position to magnify.  
The magnification is doubled around the center of the click. Cli
again to zoom in further. 

♦ Click and drag a bounding box around the region of interest to 
magnify, as shown below. 

ck 

 

alMap changes the position scale to centeSign r the selected region in 
 below. the document window, as shown
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To zoom out (decre

1. Click the Zoom b

ase magnification): 

ing: 

nd click the position at which to decrease 

♦ Choose View -> Zoom Out. 

utton on the toolbar. 
The cursor becomes a magnifying glass. 

2. Choose between the follow

♦ Hold down the Ctrl key a
the magnification.  
The magnification is halved around the center of the click. Repeat as 
needed to zoom out to your desired view. 

♦ Press Ctrl + -. 

Tip: -> Full Zoom Out or press   To zoom out completely, choose View 
Ctrl + 0. 

Tip:  in or out. 

Changing the Track Height 
. 

Cho

♦ is scale. 
ze cursor as 

 You can also use the right mouse button to zoom

The track height can be adjusted to show more detail

To change the track height: 

ose between the following: 

Place the mouse over the region under the track’s y-ax
A track separator displays and the cursor changes to a resi
shown below. 

 

Then click and drag the separator to the new track height. 
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♦ ht. Select a track and choose Track -> Set Heig
The Track Height dialog box appears. 

 

Changing the Y A
e minimum to the maximum data 

 that zero is also displayed. You can 

To 

1. ks to adjust. 

Si

Enter the new pixel height for the track. Then click OK. 

xis 
The y axis is automatically scaled from th
within each track, while ensuring
manually adjust the extent of any y-axis scale. 

manually set the y-axis scale: 

Select the trac

2. Choose View -> Manual Scale or click the Set Manual Scale button on 
the toolbar. 

gnalMap displays the Scale Settings dialog box, shown below. 

 

3. Enter the minimum and maximum value for the y-axis scale. 
SignalMap sets all selected tracks to display with a manual y-axis scale. 

Note: Annotation does not have scale data, and its scale does not change.

To automatically set the y-axis scale: 

 

1. Select the tracks to adjust. 

le or click the Set Auto Scale button on the 

th an automatic y-axis 

2. Choose View -> Auto Sca
toolbar. 
SignalMap sets all selected tracks to display wi
scale. 
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Not u manually set a y-axis scale, it is possible that data will fall e: If yo
outside of the track. This data will be clipped and colored red as 
shown in the example below. 

  

SignalMap displays track data in different ways depending on the data type 
and the number of data points. Annotation displays as vertical bars while 

Changing the Track Style 

experim ata displays as points when possible. When SignalMap is 
dra

. 

> Style and select a new style. 

ent d
wing a track with more than 24,576 points, it always draws the data as 

bars for performance reasons. When drawing points, SignalMap displays 
data as horizontal lines spanning from the start to end position. 

To change the track style: 

1. Select the track

2. Choose Track -
SignalMap displays the data in the new style: 

Points

 

Points (close up) 

 

Bars
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Changing the Tra k
ch track is dependent on the type of data. In addition, 

 source may have color annotation that overrides the track color. You 
override the data source color if it exists in the GFF file. 

d choose 

c  Color 
The color used for ea
the data
cannot 

To change the track color: 

1. Select a track. 

2. Choose Track -> Set Color, or right-click the selected track an
Set Color. 
SignalMap displays the Color dialog box. 

 

3. Choose the new track color. 

4. Click OK. 

Highlighting Trac
Signa se one track as a cursor track. When you click on a data 
point in this track, SignalMap displays a transparent gray bar over all tracks 

 the cursor track. In addition, information about 

In the example below, a positive data point on the gene track and an exon 
valu ta point. 

ks 
lMap can u

at the position of the data in
the data point appears on the fourth line in the Information area. 

e on the reverse strand share position with the selected da
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Note: More than one data point can be located on the same position on a 
track. Use the arrow keys to move the cursor to another data point on 
the track. 

To select a cursor track: 

1. 

Item to jump to the next data point on the track.  
 
To jump to the previous data point, press the left arrow key or choose 
Cursor -> Previous Item. 

Using the Pointer tool, select a track by clicking to the left of the y scale 
of the track. 
The track is selected and a blue bar overlays the y scale. 

2. Choose Track -> Attach Cursor or right-click the track and choose Attach 
Cursor or press Alt + A. 
The data in the track is associated with the cursor. 

3. To detach the cursor from a previously selected track, choose Track -> 
Detach Cursor or press Alt + A. 

To highlight a data point: 

1. Using the Pointer tool, click near the data point to highlight. 
SignalMap displays a transparent gray bar over all tracks at the position 
of the selected data point.  

2. View attribute information about the selected data point in the Cursor Info 
line of the document window.  
This information may include hyperlinks, described on the next page 

To jump to the next or previous data point: 

1. Press the right arrow key on your keyboard or choose Cursor -> Next 
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SignalMap displays a transparent gray bar over all tracks at the position 
of the selected data point. 

rest on the track. 

en the Next Item command 
gion already selected. The 

2. To view attribute information about other tracks in the region, place your 
mouse over the selected area on the track. You do not need to click a 
point, simply hover over the area of inte

The following image shows what happens wh
goes to a data point located within the data re
right half of the previously selected region is now highlighted. 

 

Using Hyperlinks 
SignalMap allows you to activate hyperlinks included in the attributes field of 
the GFF file. Typically, attributes will be placed on gene data so you can link 
to web sites describing specific genes. 

To activate a hyperlink: 

1. Put your mouse over a data point of interest. 
The attribute information displays. The data point displays with a light 
blue transparent shade if there is an available hyperlink. 

2. Double-click the data point. 
SignalMap opens your default browser to the hyperlink, as shown in the 
following image. 
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Chapter 4. Exporting Your Data 

SignalMap allows you to export a selection of your data to a GFF file. In this 
chapter, you learn to: 

♦ Select data 

♦ Export selections to a GFF file 

♦ Export a screen capture 

Selecting Data 
You can select data in each pane based on position. If you do not use the 
Control key while selecting a region of data, SignalMap maintains the 
selection for each pane independently. 

To select one region of data for export: 

1. Click the Pointer tool. 

2. Use the left mouse button to click and drag around the data of interest, 
as shown at right in the following image.  
A transparent blue rectangle displays over the selected data, as shown 
at left in the following image. 

 

To select multiple regions of data for export: 

1. Click the Pointer button on the toolbar. 

2. Click and drag around the data of interest.  
A transparent blue rectangle displays over the selected data, as shown 
on the left side of the previous image. 
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3. Press the Ctrl key and click to select additional areas. 

Tip: Multiple selections will be maintained between panes if you hold down 
the Ctrl key. This will allow you to export selections in multiple panes 
as GFF files. However, you may not export selected areas as images. 

A transparent blue rectangle appears over all selected data regions, as 
shown in the following image. 

 

Tip: Choose Edit -> Select All to select all data in the pane. 

Exporting Selections to a GFF File 
SignalMap exports selected data in the order that it was selected. It does not 
attempt to remove duplicate data. If you used the Control key to select 
multiple regions from different panes, all your selected data will be exported 
to the GFF file. 

To export selected data: 

1. Select File -> Export -> Selections from the menu.  
A File dialog box appears. 

2. Enter the filename and select the type (GFF or TXT). 

3. Click Save to save your selections. 
SignalMap saves the selected data from all panes into the file. You may 
now open this GFF file in SignalMap as you would any other GFF file. 
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Exporting a Screen Capture 
SignalMap can export a screen capture (an image of the currently displayed 
screen) as any of the following image file types: 

♦ WMF (Windows Metafile): This format can be imported into Microsoft 
Office products or any software that can read WMF files. This file type is 
useful for large presentations since the resolution scales with the size. 

♦ BMP (Bitmap file): This is a standard Windows bitmap file. It is not 
compressed and can take up a lot of disk space. 

♦ GIF (Graphics Interchange Format): A standard lossy compressed image 
format used widely for graphics on the web. 

♦ PNG (Portable Network Graphics): A standard lossless image format for 
web and image editing purposes. This format works well for large pixel 
widths. PNG files give the best results. 

♦ 
st image editing software can open 

this format. 

TIFF (Tagged Image File Format): A standard image format often used 
for high-quality print applications. Mo

Note: The exported image contains all tracks after the first displayed track   
in the pane. This makes it possible to export all tracks on a pane, even 
if the vertical image size would be larger than your display. This is 
likely if you export the screen in the All Tracks pane, as shown in the 
following image. 
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To export a screen capture as a Windows metafile: 

1. Scroll to and magnify the area of interest.  
Remember SignalMap will export any tracks that appear below those 
shown on your screen. 

2. Choose File -> Export -> Metafile Capture. 
The Save As dialog box appears. 

3. Type in the file name and click Save.  
The image saves to the selected file. You may then open it in any 
application that supports the WMF file type. 

To export a screen capture as a BMP, GIF, PNG, or TIFF: 

1. Scroll to and magnify the area of interest.  
Remember SignalMap will export any tracks that appear below those 
shown on your screen. 

2. Choose File -> Export -> Image Capture.  
The Export Image dialog box appears. 

 

3. Enter your desired image width (in pixels).  
The default setting is 1,024 pixels, and the maximum width is 32,768 
pixels. When you save the file, SignalMap resizes the screen shot to fit 
the width you selected. This feature allows you to create images of set 
widths for your publications. 

4. Select a file type from the Image Type drop-down menu.  
See the description of file types on page 37 if you are not sure which file 
type to choose. 

5. Click OK. 
The Save As dialog box appears. 
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6. Type your file name and click Save. 
Your image is saved. 

You can now open your image in image editing software. In the following 
example, the image was saved with a width of 800 pixels, causing a 
resizing of the original image as well as a change to the x-axis scale from 
that displayed on the SignalMap screen. 

 

Note: The exported image may display a different position scale than that 
shown on the SignalMap screen; however, the position range will be 
the same. 
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Appendix A. GFF Files 

GFF (General Feature Format) is a standard file format to describe genome 
data. The Sanger Institute defines the file format; see 
www.sanger.ac.uk/Software/formats/GFF/. Below is a summary of the 
format. 

Understanding GFF Files 
SignalMap imports and exports GFF files. There is no header in a GFF file. 
However, you can add a comment line that describes the file’s contents by 
using a pound sign (#) at the beginning of the line. 

Each line of data is tab delimited and has the following information in the 
order specified. For a complete description of the format, see 
www.sanger.ac.uk/Software/formats/GFF/. 

<seqname> <source> <feature> <start> <end> <score> <strand> <frame> 
[attributes] [comments] 

SignalMap does not use some of these fields; however, all fields are 
maintained in memory. 

seqname 
The sequence name used by SignalMap to separate the data into panes. 
This is limited to 32,768 panes. SignalMap can handle more than this, but 
having more than this number makes it difficult to browse for panes in the 
Pane Selector. 

source 
SignalMap does not use this. 

feature 
The feature type name used by SignalMap to separate the data into tracks. 

start 
This is used by SignalMap to display the start position. 

end 
This is used by SignalMap to display the end position. 

score 
This is used by SignalMap to display the data value (magnitude). It is ignored 
for the gene tracks. In some cases (such as exon data), the score refers to 
the confidence level of the prediction. For data tracks, the score either refers 
to a data value or the ratio of two data values (sample over the total). 
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strand 
This is used by SignalMap to place gene, exon, or other relevant data above 
or below the track line. 

Data tracks do not contain strand information: a plus sign is placed in this 
field in all data tracks. The score (see above) determines whether data on a 
“data track” is placed above or below the track line. 

frame 
SignalMap does not use this. 

attributes 
This is used by SignalMap to display extra information about the data. 
Hyperlinks can be included in the attribute, separated by semicolons (;), and 
URLs can be specified using the GFF3 tag format, url=urlpath. Color can be 
specified for the data point by placing color RRGGBB, where RRGGBB are 
the red, green and blue components of the color in web color format. For 
example, color xFF0000 will change the data point to red. 

comments 
SignalMap does not use this. 

Examples in Text File Format 
seqname source feature start end score strand frame attributes 
chrX UW data 1950 3077 -0.28 + . HSAP0307S00028922 
chrX UW gene 4099 6290 1.00 - . http://www.gene.com;H7898   
chrX UT exon 7800 9068 670 - . gene_id "exon(1044-)"  
ENm001 UT data_IgG 1 51 1225 + . ENm000P0000000001 
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Appendix B. Reporting Bugs 

You can send information regarding the nature of a SignalMap problem to 
NimbleGen. Send the email to bugreports@NimbleGen.com and include as 
much of the following information as possible. 

To report unexpected or undesired operations: 

1. Attempt to repeat the sequence of events that led you to the problem, 
and try to determine the smallest number of steps that will cause the 
problem. Describe each step in your bug report. 

2. Describe in as much detail as possible the nature of the problem and the 
steps that you took to solve to the problem. 

3. If possible, save and attach the GFF file that is related to the problem. 

4. Email this information to bugreports@NimbleGen.com. 

To report an unexpected application termination or crash: 

1. Gather the information described in the “To report unexpected or 
undesired operations” task above. Type it into a new email message. 

2. Capture the information regarding the state of the system. This 
information is found in different places depending on your operating 
system: 

♦ Windows 98 or Windows ME: An error dialog box appears. 

 
1. Click the Details button. 

2. Copy and paste the text information from this dialog box into the 
email message you began earlier. Send to 
bugreports@NimbleGen.com. 
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♦ Windows 2000 or Windows XP: A Program Error dialog box appears. 

 
1. Search your computer for the DrWtsn32.log file. The default 

location is C:\Documents and Settings\All 
Users\Documents\DrWatson\DrWtsn32.log. 

2. Attach this file to your email, or copy and paste the last part of 
the file relating to SignalMap into your email and send to 
bugreports@NimbleGen.com. 
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